Vulnerability  oval:org.opensuse.security:def:20090022
CVE-2009-0022  

Samba 3.2.0 through 3.2.6, when registry shares are enabled, allows remote authenticated users to access the root filesystem via a crafted connection request that specifies a blank share name.

Affected Platforms/Products

Affected Products (CPE + CVE references)
Platforms: unix (from OVAL definitions)
  • openSUSE 11.1
  • openSUSE 11.1 DEBUGINFO

References

Criteria

The system is vulnerable
IF : Any one of the following are true
IF : All of the following are true
IF : suse111 is installed
Linux : RPM Test :  openSUSE-release is ==11.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
openSUSE-release
version equals 11.1
linux : rpminfo_state 
IF : Any one of the following are true
IF : libwbclient-devel less than 3.2.6-0.3.1
Linux : RPM Test :  libwbclient-devel is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libwbclient-devel
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : keyutils less than 1.2-107.9
Linux : RPM Test :  keyutils is <1.2-107.9 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
keyutils
RPM Version less than 0:1.2-107.9 (datatype=evr_string)
linux : rpminfo_state 
IF : keyutils less than 1.2-107.4
Linux : RPM Test :  keyutils is <1.2-107.4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
keyutils
RPM Version less than 0:1.2-107.4 (datatype=evr_string)
linux : rpminfo_state 
IF : cifs-mount less than 3.2.6-0.3.1
Linux : RPM Test :  cifs-mount is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
cifs-mount
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libwbclient0-32bit less than 3.2.6-0.3.1
Linux : RPM Test :  libwbclient0-32bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libwbclient0-32bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libwbclient0-64bit less than 3.2.6-0.3.1
Linux : RPM Test :  libwbclient0-64bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libwbclient0-64bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-32bit less than 3.2.6-0.3.1
Linux : RPM Test :  samba-32bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-32bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-vscan less than 0.3.6b-5.3.1
Linux : RPM Test :  samba-vscan is <0.3.6b-5.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-vscan
RPM Version less than 0:0.3.6b-5.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-devel less than 3.2.6-0.3.1
Linux : RPM Test :  samba-devel is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-devel
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-client less than 3.2.6-0.3.1
Linux : RPM Test :  samba-client is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-client
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-client-32bit less than 3.2.6-0.3.1
Linux : RPM Test :  samba-client-32bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-client-32bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-64bit less than 3.2.6-0.3.1
Linux : RPM Test :  samba-64bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-64bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : ldapsmb less than 1.34b-5.3.1
Linux : RPM Test :  ldapsmb is <1.34b-5.3.1 
At least one of the objects listed below must exist on the system (Existence check)
RPM Version less than 0:1.34b-5.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba less than 3.2.6-0.3.1
Linux : RPM Test :  samba is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-winbind less than 3.2.6-0.3.1
Linux : RPM Test :  samba-winbind is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-winbind
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-winbind-64bit less than 3.2.6-0.3.1
Linux : RPM Test :  samba-winbind-64bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-winbind-64bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-winbind-32bit less than 3.2.6-0.3.1
Linux : RPM Test :  samba-winbind-32bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-winbind-32bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libsmbclient0 less than 3.2.6-0.3.1
Linux : RPM Test :  libsmbclient0 is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libsmbclient0
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libsmbclient0-32bit less than 3.2.6-0.3.1
Linux : RPM Test :  libsmbclient0-32bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libsmbclient0-32bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libsmbclient0-64bit less than 3.2.6-0.3.1
Linux : RPM Test :  libsmbclient0-64bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libsmbclient0-64bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libsmbclient-devel less than 3.2.6-0.3.1
Linux : RPM Test :  libsmbclient-devel is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libsmbclient-devel
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libnetapi0 less than 3.2.6-0.3.1
Linux : RPM Test :  libnetapi0 is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libnetapi0
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libnetapi-devel less than 3.2.6-0.3.1
Linux : RPM Test :  libnetapi-devel is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libnetapi-devel
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libtalloc1-32bit less than 3.2.6-0.3.1
Linux : RPM Test :  libtalloc1-32bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libtalloc1-32bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libtalloc1-64bit less than 3.2.6-0.3.1
Linux : RPM Test :  libtalloc1-64bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libtalloc1-64bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libtalloc1 less than 3.2.6-0.3.1
Linux : RPM Test :  libtalloc1 is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libtalloc1
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libtdb-devel less than 3.2.6-0.3.1
Linux : RPM Test :  libtdb-devel is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libtdb-devel
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libsmbsharemodes-devel less than 3.2.6-0.3.1
Linux : RPM Test :  libsmbsharemodes-devel is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libsmbsharemodes-devel
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libsmbsharemodes0 less than 3.2.6-0.3.1
Linux : RPM Test :  libsmbsharemodes0 is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libsmbsharemodes0
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libtalloc-devel less than 3.2.6-0.3.1
Linux : RPM Test :  libtalloc-devel is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libtalloc-devel
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-krb-printing less than 3.2.6-0.3.1
Linux : RPM Test :  samba-krb-printing is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-krb-printing
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-client-64bit less than 3.2.6-0.3.1
Linux : RPM Test :  samba-client-64bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-client-64bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libwbclient0 less than 3.2.6-0.3.1
Linux : RPM Test :  libwbclient0 is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libwbclient0
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libtdb1-32bit less than 3.2.6-0.3.1
Linux : RPM Test :  libtdb1-32bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libtdb1-32bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libtdb1 less than 3.2.6-0.3.1
Linux : RPM Test :  libtdb1 is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libtdb1-64bit less than 3.2.6-0.3.1
Linux : RPM Test :  libtdb1-64bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libtdb1-64bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : Any one of the following are true
IF : All of the following are true
IF : suse111 is installed
Linux : RPM Test :  openSUSE-release is ==11.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
openSUSE-release
version equals 11.1
linux : rpminfo_state 
IF : Any one of the following are true
IF : samba less than 3.2.6-0.3.1
Linux : RPM Test :  samba is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-winbind less than 3.2.6-0.3.1
Linux : RPM Test :  samba-winbind is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-winbind
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-winbind-64bit less than 3.2.6-0.3.1
Linux : RPM Test :  samba-winbind-64bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-winbind-64bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-winbind-32bit less than 3.2.6-0.3.1
Linux : RPM Test :  samba-winbind-32bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-winbind-32bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-vscan less than 0.3.6b-5.3.1
Linux : RPM Test :  samba-vscan is <0.3.6b-5.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-vscan
RPM Version less than 0:0.3.6b-5.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-krb-printing less than 3.2.6-0.3.1
Linux : RPM Test :  samba-krb-printing is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-krb-printing
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-devel less than 3.2.6-0.3.1
Linux : RPM Test :  samba-devel is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-devel
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-client less than 3.2.6-0.3.1
Linux : RPM Test :  samba-client is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-client
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-client-64bit less than 3.2.6-0.3.1
Linux : RPM Test :  samba-client-64bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-client-64bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-client-32bit less than 3.2.6-0.3.1
Linux : RPM Test :  samba-client-32bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-client-32bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-64bit less than 3.2.6-0.3.1
Linux : RPM Test :  samba-64bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-64bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-32bit less than 3.2.6-0.3.1
Linux : RPM Test :  samba-32bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-32bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libwbclient0 less than 3.2.6-0.3.1
Linux : RPM Test :  libwbclient0 is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libwbclient0
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libwbclient0-32bit less than 3.2.6-0.3.1
Linux : RPM Test :  libwbclient0-32bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libwbclient0-32bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libtdb-devel less than 3.2.6-0.3.1
Linux : RPM Test :  libtdb-devel is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libtdb-devel
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libwbclient-devel less than 3.2.6-0.3.1
Linux : RPM Test :  libwbclient-devel is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libwbclient-devel
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libtdb1-32bit less than 3.2.6-0.3.1
Linux : RPM Test :  libtdb1-32bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libtdb1-32bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libtdb1-64bit less than 3.2.6-0.3.1
Linux : RPM Test :  libtdb1-64bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libtdb1-64bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libtdb1 less than 3.2.6-0.3.1
Linux : RPM Test :  libtdb1 is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libtalloc1 less than 3.2.6-0.3.1
Linux : RPM Test :  libtalloc1 is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libtalloc1
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libtalloc1-64bit less than 3.2.6-0.3.1
Linux : RPM Test :  libtalloc1-64bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libtalloc1-64bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libtalloc-devel less than 3.2.6-0.3.1
Linux : RPM Test :  libtalloc-devel is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libtalloc-devel
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libtalloc1-32bit less than 3.2.6-0.3.1
Linux : RPM Test :  libtalloc1-32bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libtalloc1-32bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libsmbsharemodes-devel less than 3.2.6-0.3.1
Linux : RPM Test :  libsmbsharemodes-devel is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libsmbsharemodes-devel
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libsmbsharemodes0 less than 3.2.6-0.3.1
Linux : RPM Test :  libsmbsharemodes0 is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libsmbsharemodes0
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libsmbclient0 less than 3.2.6-0.3.1
Linux : RPM Test :  libsmbclient0 is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libsmbclient0
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libsmbclient0-64bit less than 3.2.6-0.3.1
Linux : RPM Test :  libsmbclient0-64bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libsmbclient0-64bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libsmbclient0-32bit less than 3.2.6-0.3.1
Linux : RPM Test :  libsmbclient0-32bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libsmbclient0-32bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libsmbclient-devel less than 3.2.6-0.3.1
Linux : RPM Test :  libsmbclient-devel is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libsmbclient-devel
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libnetapi0 less than 3.2.6-0.3.1
Linux : RPM Test :  libnetapi0 is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libnetapi0
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : cifs-mount less than 3.2.6-0.3.1
Linux : RPM Test :  cifs-mount is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
cifs-mount
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : ldapsmb less than 1.34b-5.3.1
Linux : RPM Test :  ldapsmb is <1.34b-5.3.1 
At least one of the objects listed below must exist on the system (Existence check)
RPM Version less than 0:1.34b-5.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libwbclient0-64bit less than 3.2.6-0.3.1
Linux : RPM Test :  libwbclient0-64bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libwbclient0-64bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libnetapi-devel less than 3.2.6-0.3.1
Linux : RPM Test :  libnetapi-devel is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libnetapi-devel
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : All of the following are true
IF : suse111-debug is installed
Linux : RPM Test :  openSUSE-release is ==11.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
openSUSE-release
version equals 11.1
linux : rpminfo_state 
IF : Any one of the following are true
IF : samba less than 3.2.6-0.3.1
Linux : RPM Test :  samba is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-winbind less than 3.2.6-0.3.1
Linux : RPM Test :  samba-winbind is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-winbind
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : ldapsmb less than 1.34b-5.3.1
Linux : RPM Test :  ldapsmb is <1.34b-5.3.1 
At least one of the objects listed below must exist on the system (Existence check)
RPM Version less than 0:1.34b-5.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-winbind-32bit less than 3.2.6-0.3.1
Linux : RPM Test :  samba-winbind-32bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-winbind-32bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-devel less than 3.2.6-0.3.1
Linux : RPM Test :  samba-devel is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-devel
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-vscan less than 0.3.6b-5.3.1
Linux : RPM Test :  samba-vscan is <0.3.6b-5.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-vscan
RPM Version less than 0:0.3.6b-5.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-krb-printing less than 3.2.6-0.3.1
Linux : RPM Test :  samba-krb-printing is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-krb-printing
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-client less than 3.2.6-0.3.1
Linux : RPM Test :  samba-client is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-client
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-client-32bit less than 3.2.6-0.3.1
Linux : RPM Test :  samba-client-32bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-client-32bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : samba-32bit less than 3.2.6-0.3.1
Linux : RPM Test :  samba-32bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
samba-32bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libwbclient0 less than 3.2.6-0.3.1
Linux : RPM Test :  libwbclient0 is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libwbclient0
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libwbclient0-32bit less than 3.2.6-0.3.1
Linux : RPM Test :  libwbclient0-32bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libwbclient0-32bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libnetapi-devel less than 3.2.6-0.3.1
Linux : RPM Test :  libnetapi-devel is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libnetapi-devel
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libtalloc1 less than 3.2.6-0.3.1
Linux : RPM Test :  libtalloc1 is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libtalloc1
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libtalloc1-32bit less than 3.2.6-0.3.1
Linux : RPM Test :  libtalloc1-32bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libtalloc1-32bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libsmbsharemodes-devel less than 3.2.6-0.3.1
Linux : RPM Test :  libsmbsharemodes-devel is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libsmbsharemodes-devel
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libsmbsharemodes0 less than 3.2.6-0.3.1
Linux : RPM Test :  libsmbsharemodes0 is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libsmbsharemodes0
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libtalloc-devel less than 3.2.6-0.3.1
Linux : RPM Test :  libtalloc-devel is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libtalloc-devel
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libtdb-devel less than 3.2.6-0.3.1
Linux : RPM Test :  libtdb-devel is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libtdb-devel
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libwbclient-devel less than 3.2.6-0.3.1
Linux : RPM Test :  libwbclient-devel is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libwbclient-devel
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libtdb1 less than 3.2.6-0.3.1
Linux : RPM Test :  libtdb1 is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libtdb1-32bit less than 3.2.6-0.3.1
Linux : RPM Test :  libtdb1-32bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libtdb1-32bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : cifs-mount less than 3.2.6-0.3.1
Linux : RPM Test :  cifs-mount is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
cifs-mount
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libsmbclient0 less than 3.2.6-0.3.1
Linux : RPM Test :  libsmbclient0 is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libsmbclient0
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libsmbclient0-32bit less than 3.2.6-0.3.1
Linux : RPM Test :  libsmbclient0-32bit is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libsmbclient0-32bit
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libsmbclient-devel less than 3.2.6-0.3.1
Linux : RPM Test :  libsmbclient-devel is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libsmbclient-devel
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 
IF : libnetapi0 less than 3.2.6-0.3.1
Linux : RPM Test :  libnetapi0 is <3.2.6-0.3.1 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
libnetapi0
RPM Version less than 0:3.2.6-0.3.1 (datatype=evr_string)
linux : rpminfo_state 

Quick Help

evr_string datatype
Represents epoch, version, and release number as a single version string
Other Help Topics
Data Types
What is an Object?
What is a State?
What is a Test?
Other Help Topics
Regular Expression Patterns
Some object or state definitions are defined as regular expression patterns, you should interpret the regexp pattern while evaluating them.

OVAL Definitions By Referenced Objects

How does it work?   User agreement and privacy statement   About & Contact
CVE is a registred trademark of the MITRE Corporation and the authoritive source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritive source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritive source of OVAL content is MITRE's OVAL web site.
Warning: This site and all data are provided as is. It is not guaranteed that all information is accurate and complete. Use any information provided on this site at your own risk. By using this site you accept that you know that these data are provided as is and not guaranteed to be accurate, correct or complete. All trademarks appearing on this site are the property of their respective owners in the US or other countries. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss. PLEASE SEE nvd.nist.gov and oval.mitre.org for more details about OVAL language and definitions.
The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor/web site owner/maintainer be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.
Use of OVAL and all related data is subject to terms of use defined by Mitre at http://oval.mitre.org/oval/about/termsofuse.html