Vulnerability  oval:org.mitre.oval:def:7170
VBScript Help Keypress Vulnerability  

vbscript.dll in VBScript 5.1, 5.6, 5.7, and 5.8 in Microsoft Windows 2000 SP4, XP SP2 and SP3, and Server 2003 SP2, when Internet Explorer is used, allows user-assisted remote attackers to execute arbitrary code by referencing a (1) local pathname, (2) UNC share pathname, or (3) WebDAV server with a crafted .hlp file in the fourth argument (aka helpfile argument) to the MsgBox function, leading to code execution involving winhlp32.exe when the F1 key is pressed, aka "VBScript Help Keypress Vulnerability."
Create Date: 2010-03-13 Last Update Date: 2015-08-10

Affected Platforms/Products

Affected Products (CPE + CVE references)
Platforms: windows (from OVAL definitions) Products: windows
  • Microsoft Windows Server 2008 R2
  • Microsoft Windows Server 2008
  • Microsoft Windows 7
  • Microsoft Windows Server 2003
  • Microsoft Windows Vista
  • Microsoft Windows XP
  • VBScript 5.8
  • VBScript 5.7
  • VBScript 5.6
  • VBScript 5.1

References

Criteria

The system is vulnerable
IF : Any one of the following are true
IF : All of the following are true Vulnerable VBScript 5.8 on Microsoft Windows 7 x86/x64, Windows Server 2008 R2 x86/x64/ia64 - LDR
Prerequisites (Extended Definitions)
VBScript 5.8 is installed oval:org.mitre.oval:def:28109
IF : Vbscript.dll version is greater than or equal 5.8.7600.20000
Windows : File Test :  Vbscript.dll version is greater than or equal 5.8.7600.20000 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File 
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\System32\vbscript.dll
version greater than or equal 5.8.7600.20000 (datatype=version)
windows : file_state 
IF : Vbscript.dll version is less than 5.8.7600.20662
Windows : File Test :  Vbscript.dll version is less than 5.8.7600.20662 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File 
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\System32\vbscript.dll
version less than 5.8.7600.20662 (datatype=version)
windows : file_state 
IF : Any one of the following are true 7 x86/x64, Server 2008 R2 x64/ia64
Prerequisites (Extended Definitions)
Microsoft Windows Server 2008 R2 x64 Edition is installed oval:org.mitre.oval:def:6438
Microsoft Windows Server 2008 R2 Itanium-Based Edition is installed oval:org.mitre.oval:def:5954
Microsoft Windows 7 (32-bit) is installed oval:org.mitre.oval:def:6165
Microsoft Windows 7 x64 Edition is installed oval:org.mitre.oval:def:5950
IF : All of the following are true Vulnerable VBScript 5.8 on Microsoft Windows 7 x86/x64, Windows Server 2008 R2 x86/x64/ia64 - GDR
Prerequisites (Extended Definitions)
VBScript 5.8 is installed oval:org.mitre.oval:def:28109
IF : Vbscript.dll version is less than 5.8.7600.16546
Windows : File Test :  Vbscript.dll version is less than 5.8.7600.16546 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File 
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\System32\vbscript.dll
version less than 5.8.7600.16546 (datatype=version)
windows : file_state 
IF : Vbscript.dll version is greater than or equal 5.8.7600.16000
Windows : File Test :  Vbscript.dll version is greater than or equal 5.8.7600.16000 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File 
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\System32\vbscript.dll
version greater than or equal 5.8.7600.16000 (datatype=version)
windows : file_state 
IF : Any one of the following are true 7 x86/x64, Server 2008 R2 x64/ia64
Prerequisites (Extended Definitions)
Microsoft Windows Server 2008 R2 Itanium-Based Edition is installed oval:org.mitre.oval:def:5954
Microsoft Windows Server 2008 R2 x64 Edition is installed oval:org.mitre.oval:def:6438
Microsoft Windows 7 x64 Edition is installed oval:org.mitre.oval:def:5950
Microsoft Windows 7 (32-bit) is installed oval:org.mitre.oval:def:6165
IF : All of the following are true Vulnerable VBScript 5.8 on Microsoft Windows Vista x86/x64, Server 2008 SP2 32bit/x64 - LDR
Prerequisites (Extended Definitions)
VBScript 5.8 is installed oval:org.mitre.oval:def:28109
IF : Vbscript.dll version is less than 5.8.6001.23000
Windows : File Test :  Vbscript.dll version is less than 5.8.6001.23000 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File 
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\System32\vbscript.dll
version less than 5.8.6001.23000 (datatype=version)
windows : file_state 
IF : Vbscript.dll version is greater than or equal 5.8.6001.22000
Windows : File Test :  Vbscript.dll version is greater than or equal 5.8.6001.22000 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File 
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\System32\vbscript.dll
version greater than or equal 5.8.6001.22000 (datatype=version)
windows : file_state 
IF : Any one of the following are true Vista x86/x64, Server 2008 x86/x64/ia64
Prerequisites (Extended Definitions)
Microsoft Windows Server 2008 (ia-64) is installed oval:org.mitre.oval:def:5667
Microsoft Windows Server 2008 (64-bit) is installed oval:org.mitre.oval:def:5356
Microsoft Windows Server 2008 (32-bit) is installed oval:org.mitre.oval:def:4870
Microsoft Windows Vista x64 Edition is installed oval:org.mitre.oval:def:2041
Microsoft Windows Vista (32-bit) is installed oval:org.mitre.oval:def:1282
IF : All of the following are true Vulnerable VBScript 5.8 on All Microsoft Windows Vista x86/x64, Server 2008 32bit/x64 - GDR
Prerequisites (Extended Definitions)
VBScript 5.8 is installed oval:org.mitre.oval:def:28109
IF : Vbscript.dll version is less than 5.8.6001.18909
Windows : File Test :  Vbscript.dll version is less than 5.8.6001.18909 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File 
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\System32\vbscript.dll
version less than 5.8.6001.18909 (datatype=version)
windows : file_state 
IF : Vbscript.dll version is greater than or equal 5.8.6001.18000
Windows : File Test :  Vbscript.dll version is greater than or equal 5.8.6001.18000 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File 
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\System32\vbscript.dll
version greater than or equal 5.8.6001.18000 (datatype=version)
windows : file_state 
IF : Any one of the following are true Vista x86/x64, Server 2008 x86/x64/ia64
Prerequisites (Extended Definitions)
Microsoft Windows Server 2008 (ia-64) is installed oval:org.mitre.oval:def:5667
Microsoft Windows Server 2008 (64-bit) is installed oval:org.mitre.oval:def:5356
Microsoft Windows Server 2008 (32-bit) is installed oval:org.mitre.oval:def:4870
Microsoft Windows Vista (32-bit) is installed oval:org.mitre.oval:def:1282
Microsoft Windows Vista x64 Edition is installed oval:org.mitre.oval:def:2041
IF : All of the following are true VBScript 5.8 on Windows 2000, XP, Server 2003
Prerequisites (Extended Definitions)
VBScript 5.8 is installed oval:org.mitre.oval:def:28109
IF : Vbscript.dll version is less than 5.8.6001.23000
Windows : File Test :  Vbscript.dll version is less than 5.8.6001.23000 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File 
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\System32\vbscript.dll
version less than 5.8.6001.23000 (datatype=version)
windows : file_state 
IF : Any one of the following are true OS section
Prerequisites (Extended Definitions)
Microsoft Windows Server 2003 (x64) is installed oval:org.mitre.oval:def:730
Microsoft Windows Server 2003 (32-bit) is installed oval:org.mitre.oval:def:1870
Microsoft Windows XP x64 is installed oval:org.mitre.oval:def:15247
Microsoft Windows XP (32-bit) is installed oval:org.mitre.oval:def:1353
Microsoft Windows 2000 is installed oval:org.mitre.oval:def:85
IF : All of the following are true Vulnerable VBScript 5.7 on Microsoft Windows Vista x86/x64, Server 2008 32bit/x64/ia64 - LDR
Prerequisites (Extended Definitions)
VBScript 5.7 is installed oval:org.mitre.oval:def:29032
IF : Vbscript.dll version is less than 5.7.6002.22354
Windows : File Test :  Vbscript.dll version is less than 5.7.6002.22354 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File 
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\System32\vbscript.dll
version less than 5.7.6002.22354 (datatype=version)
windows : file_state 
IF : Vbscript.dll version is greater than or equal 5.7.6002.22000
Windows : File Test :  Vbscript.dll version is greater than or equal 5.7.6002.22000 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File 
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\System32\vbscript.dll
version greater than or equal 5.7.6002.22000 (datatype=version)
windows : file_state 
IF : Any one of the following are true Vista x86/x64, Server 2008 32bit/x64/ia64
Prerequisites (Extended Definitions)
Microsoft Windows Server 2008 (ia-64) is installed oval:org.mitre.oval:def:5667
Microsoft Windows Server 2008 (64-bit) is installed oval:org.mitre.oval:def:5356
Microsoft Windows Vista x64 Edition is installed oval:org.mitre.oval:def:2041
Microsoft Windows Server 2008 (32-bit) is installed oval:org.mitre.oval:def:4870
Microsoft Windows Vista (32-bit) is installed oval:org.mitre.oval:def:1282
IF : All of the following are true Vulnerable VBScript 5.7 on Microsoft Windows Vista x86/x64, Server 2008 32bit/x64/ia64 - LDR
Prerequisites (Extended Definitions)
VBScript 5.7 is installed oval:org.mitre.oval:def:29032
IF : Vbscript.dll version is greater than or equal 5.7.0.22000
Windows : File Test :  Vbscript.dll version is greater than or equal 5.7.0.22000 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File 
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\System32\vbscript.dll
version greater than or equal 5.7.0.22000 (datatype=version)
windows : file_state 
IF : Vbscript.dll version is less than 5.7.0.22648
Windows : File Test :  Vbscript.dll version is less than 5.7.0.22648 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File 
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\System32\vbscript.dll
version less than 5.7.0.22648 (datatype=version)
windows : file_state 
IF : Any one of the following are true Vista x86/x64, Server 2008 x86/x64/ia64
Prerequisites (Extended Definitions)
Microsoft Windows Server 2008 (ia-64) is installed oval:org.mitre.oval:def:5667
Microsoft Windows Vista x64 Edition is installed oval:org.mitre.oval:def:2041
Microsoft Windows Server 2008 (64-bit) is installed oval:org.mitre.oval:def:5356
Microsoft Windows Server 2008 (32-bit) is installed oval:org.mitre.oval:def:4870
Microsoft Windows Vista (32-bit) is installed oval:org.mitre.oval:def:1282
IF : All of the following are true Vulnerable VBScript 5.7 on Microsoft Windows Vista x86/x64, Server 2008 32bit/x64/ia64 - GDR
Prerequisites (Extended Definitions)
VBScript 5.7 is installed oval:org.mitre.oval:def:29032
IF : Vbscript.dll version is less than 5.7.6002.18222
Windows : File Test :  Vbscript.dll version is less than 5.7.6002.18222 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File 
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\System32\vbscript.dll
version less than 5.7.6002.18222 (datatype=version)
windows : file_state 
IF : Vbscript.dll version is greater than or equal 5.7.6002.18000
Windows : File Test :  Vbscript.dll version is greater than or equal 5.7.6002.18000 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File 
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\System32\vbscript.dll
version greater than or equal 5.7.6002.18000 (datatype=version)
windows : file_state 
IF : Any one of the following are true Vista x86/x64, Server 2008 32bit/x64/ia64
Prerequisites (Extended Definitions)
Microsoft Windows Server 2008 (ia-64) is installed oval:org.mitre.oval:def:5667
Microsoft Windows Server 2008 (64-bit) is installed oval:org.mitre.oval:def:5356
Microsoft Windows Vista x64 Edition is installed oval:org.mitre.oval:def:2041
Microsoft Windows Vista (32-bit) is installed oval:org.mitre.oval:def:1282
Microsoft Windows Server 2008 (32-bit) is installed oval:org.mitre.oval:def:4870
IF : All of the following are true Vulnerable VBScript 5.7 on Microsoft Windows Vista x86/x64, Server 2008 32bit/x64/ia64 - GDR
Prerequisites (Extended Definitions)
VBScript 5.7 is installed oval:org.mitre.oval:def:29032
IF : Vbscript.dll version is less than 5.7.0.18440
Windows : File Test :  Vbscript.dll version is less than 5.7.0.18440 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File 
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\System32\vbscript.dll
version less than 5.7.0.18440 (datatype=version)
windows : file_state 
IF : Vbscript.dll version is greater than or equal 5.7.0.18000
Windows : File Test :  Vbscript.dll version is greater than or equal 5.7.0.18000 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File 
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\System32\vbscript.dll
version greater than or equal 5.7.0.18000 (datatype=version)
windows : file_state 
IF : Any one of the following are true Vista x86/x64, Server 2008 x86/x64/ia64
Prerequisites (Extended Definitions)
Microsoft Windows Server 2008 (ia-64) is installed oval:org.mitre.oval:def:5667
Microsoft Windows Server 2008 (64-bit) is installed oval:org.mitre.oval:def:5356
Microsoft Windows Server 2008 (32-bit) is installed oval:org.mitre.oval:def:4870
Microsoft Windows Vista x64 Edition is installed oval:org.mitre.oval:def:2041
Microsoft Windows Vista (32-bit) is installed oval:org.mitre.oval:def:1282
IF : All of the following are true Vulnerable VBScript 5.7 on Microsoft Windows Vista x86/x64 - LDR
Prerequisites (Extended Definitions)
VBScript 5.7 is installed oval:org.mitre.oval:def:29032
IF : Vbscript.dll version is greater than or equal 5.7.0.20000
Windows : File Test :  Vbscript.dll version is greater than or equal 5.7.0.20000 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File 
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\System32\vbscript.dll
version greater than or equal 5.7.0.20000 (datatype=version)
windows : file_state 
IF : Vbscript.dll version is less than 5.7.0.21238
Windows : File Test :  Vbscript.dll version is less than 5.7.0.21238 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File 
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\System32\vbscript.dll
version less than 5.7.0.21238 (datatype=version)
windows : file_state 
IF : Any one of the following are true Vista x86/x64
Prerequisites (Extended Definitions)
Microsoft Windows Vista (32-bit) is installed oval:org.mitre.oval:def:1282
Microsoft Windows Vista x64 Edition is installed oval:org.mitre.oval:def:2041
IF : All of the following are true Vulnerable VBScript 5.7 on Microsoft Windows Vista x86/x64 - GDR
Prerequisites (Extended Definitions)
VBScript 5.7 is installed oval:org.mitre.oval:def:29032
IF : Vbscript.dll version is greater than or equal 5.7.0.16000
Windows : File Test :  Vbscript.dll version is greater than or equal 5.7.0.16000 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File 
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\System32\vbscript.dll
version greater than or equal 5.7.0.16000 (datatype=version)
windows : file_state 
IF : Vbscript.dll version is less than 5.7.0.17033
Windows : File Test :  Vbscript.dll version is less than 5.7.0.17033 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File 
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\System32\vbscript.dll
version less than 5.7.0.17033 (datatype=version)
windows : file_state 
IF : Any one of the following are true Vista x86/x64
Prerequisites (Extended Definitions)
Microsoft Windows Vista (32-bit) is installed oval:org.mitre.oval:def:1282
Microsoft Windows Vista x64 Edition is installed oval:org.mitre.oval:def:2041
IF : All of the following are true Vulnerable VBScript 5.7 on Windows 2000, XP, Server 2003
Prerequisites (Extended Definitions)
VBScript 5.7 is installed oval:org.mitre.oval:def:29032
IF : Vbscript.dll version is less than 5.7.6002.22354
Windows : File Test :  Vbscript.dll version is less than 5.7.6002.22354 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File 
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\System32\vbscript.dll
version less than 5.7.6002.22354 (datatype=version)
windows : file_state 
IF : Any one of the following are true OS section
Prerequisites (Extended Definitions)
Microsoft Windows Server 2003 (ia64) Gold is installed oval:org.mitre.oval:def:396
Microsoft Windows Server 2003 (x64) is installed oval:org.mitre.oval:def:730
Microsoft Windows Server 2003 (32-bit) is installed oval:org.mitre.oval:def:1870
Microsoft Windows XP x64 is installed oval:org.mitre.oval:def:15247
Microsoft Windows XP (32-bit) is installed oval:org.mitre.oval:def:1353
Microsoft Windows 2000 is installed oval:org.mitre.oval:def:85
IF : All of the following are true Vulnerable VBScript 5.1 or VBScript 5.6 on Windows 2000, XP, Server 2003
IF : Vbscript.dll version is less than 5.6.0.8838
Windows : File Test :  Vbscript.dll version is less than 5.6.0.8838 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File 
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\System32\vbscript.dll
version less than 5.6.0.8838 (datatype=version)
windows : file_state 
IF : Any one of the following are true OS section
Prerequisites (Extended Definitions)
VBScript 5.1 is installed oval:org.mitre.oval:def:28636
VBScript 5.6 is installed oval:org.mitre.oval:def:28988
IF : Any one of the following are true OS section
Prerequisites (Extended Definitions)
Microsoft Windows Server 2003 (ia64) Gold is installed oval:org.mitre.oval:def:396
Microsoft Windows Server 2003 (x64) is installed oval:org.mitre.oval:def:730
Microsoft Windows Server 2003 (32-bit) is installed oval:org.mitre.oval:def:1870
Microsoft Windows XP x64 is installed oval:org.mitre.oval:def:15247
Microsoft Windows XP (32-bit) is installed oval:org.mitre.oval:def:1353
Microsoft Windows 2000 is installed oval:org.mitre.oval:def:85

Quick Help

References To Objects
[[ .. ${{...}}]] are refences to values of other objects.
Other Help Topics
Data Types
What is an Object?
What is a State?
What is a Test?
Other Help Topics
Regular Expression Patterns
Some object or state definitions are defined as regular expression patterns, you should interpret the regexp pattern while evaluating them.

OVAL Definitions By Referenced Objects

How does it work?   User agreement and privacy statement   About & Contact
CVE is a registred trademark of the MITRE Corporation and the authoritive source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritive source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritive source of OVAL content is MITRE's OVAL web site.
Warning: This site and all data are provided as is. It is not guaranteed that all information is accurate and complete. Use any information provided on this site at your own risk. By using this site you accept that you know that these data are provided as is and not guaranteed to be accurate, correct or complete. All trademarks appearing on this site are the property of their respective owners in the US or other countries. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss. PLEASE SEE nvd.nist.gov and oval.mitre.org for more details about OVAL language and definitions.
The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor/web site owner/maintainer be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.
Use of OVAL and all related data is subject to terms of use defined by Mitre at http://oval.mitre.org/oval/about/termsofuse.html