Patch  oval:gov.nist.fdcc.patch:def:11700
MS10-070: Vulnerability in ASP.NET Could Allow Information Disclosure (2418042)  

Microsoft has released MS10-070 to address security issues in as documented by CVE-2010-3332

Affected Platforms/Products

Affected Products (CPE + CVE references)
Platforms: windows (from OVAL definitions)
  • Microsoft Windows Server 2008 R2
  • Microsoft Windows 7
  • Microsoft Windows Server 2008
  • Microsoft Windows Vista
  • Microsoft Windows XP

References

Criteria

The patch should be installed
IF : Any one of the following are true
IF : All of the following are true (vista sp1/2 (32/64) OR 2008 RTM/sp2 (32/64) OR xp sp3 OR xp x64 sp2 OR 7 OR 2008 R2) AND .net 4.0
Prerequisites (Extended Definitions)
Microsoft .NET Framework 4.0, or later, is installed oval:gov.nist.fdcc.patch:def:115295
IF : Any one of the following are true GDR or LDR update has been applied
IF : System.Web.dll version is less than 4.0.30319.206
Windows : File Test :  System.Web.dll version is less than 4.0.30319.206 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File System.Web.dll
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\Microsoft.NET\Framework\v4.0.30319\system.web.dll
version less than 4.0.30319.206 (datatype=version)
version is less than 4.0.30319.206 windows : file_state 
IF : All of the following are true LDR
IF : System.Web.dll version is greater than or equal to 4.0.30319.300
Windows : File Test :  System.Web.dll version is greater than or equal to 4.0.30319.300 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File System.Web.dll
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\Microsoft.NET\Framework\v4.0.30319\system.web.dll
version greater than or equal 4.0.30319.300 (datatype=version)
version is greater than or equal to 4.0.30319.300 windows : file_state 
IF : System.Web.dll version is less than 4.0.30319.363
Windows : File Test :  System.Web.dll version is less than 4.0.30319.363 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File System.Web.dll
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\Microsoft.NET\Framework\v4.0.30319\system.web.dll
version less than 4.0.30319.363 (datatype=version)
version is less than 4.0.30319.363 windows : file_state 
IF : Any one of the following are true vista sp1/2 (32/64) OR 2008 RTM/sp2 (32/64) OR xp sp2/3 OR xp x64 sp2 OR 7 OR 2008 R2
Prerequisites (Extended Definitions)
Microsoft Windows Server 2008 Itanium-Based Edition Service Pack 2 is installed oval:org.mitre.oval:def:6150
Microsoft Windows Vista x64 Edition Service Pack 2 is installed oval:org.mitre.oval:def:5594
Microsoft Windows Server 2008 (32-bit) Service Pack 2 is installed oval:org.mitre.oval:def:5653
Microsoft Windows Vista (32-bit) Service Pack 2 is installed oval:org.mitre.oval:def:6124
Microsoft Windows Server 2008 (ia-64) is installed oval:org.mitre.oval:def:5667
Microsoft Windows Server 2008 (64-bit) is installed oval:org.mitre.oval:def:5356
Microsoft Windows Vista x64 Edition Service Pack 1 is installed oval:org.mitre.oval:def:5254
Microsoft Windows Server 2008 (32-bit) is installed oval:org.mitre.oval:def:4870
Microsoft Windows Vista (32-bit) Service Pack 1 is installed oval:org.mitre.oval:def:4873
Microsoft Windows XP x64 Edition SP2 is installed oval:org.mitre.oval:def:4193
Microsoft Windows XP (x86) SP3 is installed oval:org.mitre.oval:def:5631
Microsoft Windows Server 2008 x64 Edition Service Pack 2 is installed oval:org.mitre.oval:def:6216
IF : All of the following are true (xp sp3 OR xp x64 sp2) AND (.net 3.5 OR 3.5 sp1)
IF : Any one of the following are true .net 3.5 or 3.5 sp1
IF : All of the following are true .net 3.5 sp1
Prerequisites (Extended Definitions)
Microsoft .NET Framework 3.5 Service Pack 1, or later, is installed oval:gov.nist.fdcc.patch:def:11583
IF : System.Web.Extensions.dll version is less than 3.5.30729.3644
Windows : File Test :  System.Web.Extensions.dll version is less than 3.5.30729.3644 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File System.Web.Extensions.dll
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\AssemblyFolders\v3.5 : All Assemblies In}}]]\system.web.extensions.dll
version less than 3.5.30729.3644 (datatype=version)
version is less than 3.5.30729.3644 windows : file_state 
IF : All of the following are true .net 3.5
Prerequisites (Extended Definitions)
Microsoft .NET Framework 3.5 (Gold) is installed oval:gov.nist.fdcc.patch:def:11582
IF : Any one of the following are true
IF : Aspnet_perf.dll version is less than 2.0.50727.1887
Windows : File Test :  Aspnet_perf.dll version is less than 2.0.50727.1887 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File Aspnet_perf.dll
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\Microsoft.NET\Framework\v2.0.50727\aspnet_perf.dll
version less than 2.0.50727.1887 (datatype=version)
version is less than 2.0.50727.1887 windows : file_state 
IF : System.Web.Extensions.dll version is less than 3.5.21022.239
Windows : File Test :  System.Web.Extensions.dll version is less than 3.5.21022.239 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File System.Web.Extensions.dll
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\AssemblyFolders\v3.5 : All Assemblies In}}]]\system.web.extensions.dll
version less than 3.5.21022.239 (datatype=version)
version is less than 3.5.21022.239 windows : file_state 
IF : Any one of the following are true xp sp3 OR xp x64 sp2
Prerequisites (Extended Definitions)
Microsoft Windows XP (x86) SP3 is installed oval:org.mitre.oval:def:5631
Microsoft Windows XP x64 Edition SP2 is installed oval:org.mitre.oval:def:4193
IF : All of the following are true (vista sp1 (32/64) OR 2008 RTM (32/64)) AND .net 2.0 sp1 AND 3.5 (Gold)
Prerequisites (Extended Definitions)
Microsoft .NET Framework 3.5 (Gold) is installed oval:gov.nist.fdcc.patch:def:11582
Microsoft .NET Framework 2.0 Service Pack 1 is installed oval:org.mitre.oval:def:6428
IF : Aspnet_wp.exe version is less than 2.0.50727.1887
Windows : File Test :  Aspnet_wp.exe version is less than 2.0.50727.1887 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File Aspnet_wp.exe
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\Microsoft.NET\Framework\v2.0.50727\aspnet_wp.exe
version less than 2.0.50727.1887 (datatype=version)
version is less than 2.0.50727.1887 windows : file_state 
IF : Any one of the following are true vista sp1 (32/64) OR 2008 RTM (32/64)
Prerequisites (Extended Definitions)
Microsoft Windows Vista (32-bit) Service Pack 1 is installed oval:org.mitre.oval:def:4873
Microsoft Windows Server 2008 (64-bit) is installed oval:org.mitre.oval:def:5356
Microsoft Windows Server 2008 (ia-64) is installed oval:org.mitre.oval:def:5667
Microsoft Windows Vista x64 Edition Service Pack 1 is installed oval:org.mitre.oval:def:5254
Microsoft Windows Server 2008 (32-bit) is installed oval:org.mitre.oval:def:4870
IF : All of the following are true (7 x86/x64 OR Server 2008 R2 x64/ia64) AND .NET 3.5 sp1 - GDR
Prerequisites (Extended Definitions)
Microsoft .NET Framework 3.5 Service Pack 1, or later, is installed oval:gov.nist.fdcc.patch:def:11583
IF : Aspnet_wp.exe version is less than 2.0.50727.4955
Windows : File Test :  Aspnet_wp.exe version is less than 2.0.50727.4955 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File Aspnet_wp.exe
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\Microsoft.NET\Framework\v3.5\aspnet_wp.exe
version less than 2.0.50727.4955 (datatype=version)
version is less than 2.0.50727.4955 windows : file_state 
IF : Any one of the following are true
Prerequisites (Extended Definitions)
Microsoft Windows Server 2008 R2 Itanium-Based Edition is installed oval:org.mitre.oval:def:5954
Microsoft Windows 7 (32-bit) is installed oval:org.mitre.oval:def:6165
Microsoft Windows 7 x64 Edition is installed oval:org.mitre.oval:def:5950
Microsoft Windows Server 2008 R2 x64 Edition is installed oval:org.mitre.oval:def:6438
IF : All of the following are true (vista sp1 (32/64) OR 2008 RTM (32/64)) AND .net 3.5 (Gold)
Prerequisites (Extended Definitions)
Microsoft .NET Framework 3.5 (Gold) is installed oval:gov.nist.fdcc.patch:def:11582
IF : System.Web.Extensions.dll version is less than 3.5.21022.239
Windows : File Test :  System.Web.Extensions.dll version is less than 3.5.21022.239 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File System.Web.Extensions.dll
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\AssemblyFolders\v3.5 : All Assemblies In}}]]\system.web.extensions.dll
version less than 3.5.21022.239 (datatype=version)
version is less than 3.5.21022.239 windows : file_state 
IF : Any one of the following are true vista sp1 (32/64) OR 2008 RTM (32/64)
Prerequisites (Extended Definitions)
Microsoft Windows Server 2008 (64-bit) is installed oval:org.mitre.oval:def:5356
Microsoft Windows Vista x64 Edition Service Pack 1 is installed oval:org.mitre.oval:def:5254
Microsoft Windows Server 2008 (ia-64) is installed oval:org.mitre.oval:def:5667
Microsoft Windows Vista (32-bit) Service Pack 1 is installed oval:org.mitre.oval:def:4873
Microsoft Windows Server 2008 (32-bit) is installed oval:org.mitre.oval:def:4870
IF : All of the following are true (vista sp2 (32/64) OR 2008 sp2 (32/64)) AND 3.5 sp1 - GDR
Prerequisites (Extended Definitions)
Microsoft .NET Framework 4.0, or later, is installed oval:gov.nist.fdcc.patch:def:115295
IF : Aspnet_wp.exe version is less than 2.0.50727.4209
Windows : File Test :  Aspnet_wp.exe version is less than 2.0.50727.4209 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File Aspnet_wp.exe
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\Microsoft.NET\Framework\v3.5\aspnet_wp.exe
version less than 2.0.50727.4209 (datatype=version)
version is less than 2.0.50727.4209 windows : file_state 
IF : Any one of the following are true vista sp2 (32/64) OR 2008 sp2 (32/64)
Prerequisites (Extended Definitions)
Microsoft Windows Vista (32-bit) Service Pack 2 is installed oval:org.mitre.oval:def:6124
Microsoft Windows Server 2008 (32-bit) Service Pack 2 is installed oval:org.mitre.oval:def:5653
Microsoft Windows Vista x64 Edition Service Pack 2 is installed oval:org.mitre.oval:def:5594
Microsoft Windows Server 2008 x64 Edition Service Pack 2 is installed oval:org.mitre.oval:def:6216
Microsoft Windows Server 2008 Itanium-Based Edition Service Pack 2 is installed oval:org.mitre.oval:def:6150
IF : All of the following are true (vista sp1/2 (32/64) OR 2008 RTM/sp2 (32/64) OR xp sp3 OR xp x64 sp2 OR 7 OR 2008 R2) AND .net 1.1 sp1
Prerequisites (Extended Definitions)
Microsoft .NET Framework 1.1 Service Pack 1, or later, is Installed oval:gov.nist.fdcc.patch:def:115285
IF : Mscorsvr.dll version is less than 1.1.4322.2470
Windows : File Test :  Mscorsvr.dll version is less than 1.1.4322.2470 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File Mscorsvr.dll
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\Microsoft.NET\Framework\v1.1.4322\mscorsvr.dll
version less than 1.1.4322.2470 (datatype=version)
version is less than 1.1.4322.2470 windows : file_state 
IF : Any one of the following are true vista sp1/2 (32/64) OR 2008 RTM/sp2 (32/64) OR xp sp2/3 OR xp x64 sp2 OR 7 OR 2008 R2
Prerequisites (Extended Definitions)
Microsoft Windows Server 2008 Itanium-Based Edition Service Pack 2 is installed oval:org.mitre.oval:def:6150
Microsoft Windows Vista (32-bit) Service Pack 1 is installed oval:org.mitre.oval:def:4873
Microsoft Windows Server 2008 (32-bit) is installed oval:org.mitre.oval:def:4870
Microsoft Windows Server 2008 (64-bit) is installed oval:org.mitre.oval:def:5356
Microsoft Windows XP (x86) SP3 is installed oval:org.mitre.oval:def:5631
Microsoft Windows Vista x64 Edition Service Pack 2 is installed oval:org.mitre.oval:def:5594
Microsoft Windows Server 2008 x64 Edition Service Pack 2 is installed oval:org.mitre.oval:def:6216
Microsoft Windows Vista (32-bit) Service Pack 2 is installed oval:org.mitre.oval:def:6124
Microsoft Windows Server 2008 (ia-64) is installed oval:org.mitre.oval:def:5667
Microsoft Windows Server 2008 (32-bit) Service Pack 2 is installed oval:org.mitre.oval:def:5653
Microsoft Windows Vista x64 Edition Service Pack 1 is installed oval:org.mitre.oval:def:5254
Microsoft Windows XP x64 Edition SP2 is installed oval:org.mitre.oval:def:4193
IF : All of the following are true (vista sp2 (32/64) OR 2008 sp2 (32/64) OR 7 x86/x64 OR Server 2008 R2 x64/ia64) AND 3.5 sp1 - LDR
Prerequisites (Extended Definitions)
Microsoft .NET Framework 4.0, or later, is installed oval:gov.nist.fdcc.patch:def:115295
IF : Any one of the following are true vista sp2 (32/64) OR 2008 sp2 (32/64)
Prerequisites (Extended Definitions)
Microsoft Windows Server 2008 R2 Itanium-Based Edition is installed oval:org.mitre.oval:def:5954
Microsoft Windows Server 2008 R2 x64 Edition is installed oval:org.mitre.oval:def:6438
Microsoft Windows 7 x64 Edition is installed oval:org.mitre.oval:def:5950
Microsoft Windows 7 (32-bit) is installed oval:org.mitre.oval:def:6165
Microsoft Windows Server 2008 Itanium-Based Edition Service Pack 2 is installed oval:org.mitre.oval:def:6150
Microsoft Windows Server 2008 x64 Edition Service Pack 2 is installed oval:org.mitre.oval:def:6216
Microsoft Windows Vista x64 Edition Service Pack 2 is installed oval:org.mitre.oval:def:5594
Microsoft Windows Server 2008 (32-bit) Service Pack 2 is installed oval:org.mitre.oval:def:5653
Microsoft Windows Vista (32-bit) Service Pack 2 is installed oval:org.mitre.oval:def:6124
IF : All of the following are true LDR
IF : Aspnet_wp.exe version is less than 2.0.50727.5053
Windows : File Test :  Aspnet_wp.exe version is less than 2.0.50727.5053 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File Aspnet_wp.exe
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\Microsoft.NET\Framework\v3.5\aspnet_wp.exe
version less than 2.0.50727.5053 (datatype=version)
version is less than 2.0.50727.5053 windows : file_state 
IF : Aspnet_wp.exe version is greater than or equal to 2.0.50727.5000
Windows : File Test :  Aspnet_wp.exe version is greater than or equal to 2.0.50727.5000 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File Aspnet_wp.exe
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\Microsoft.NET\Framework\v3.5\aspnet_wp.exe
version greater than or equal 2.0.50727.5000 (datatype=version)
windows : file_state 
IF : All of the following are true (vista sp1 (32/64) OR 2008 RTM (32/64) OR xp sp3 OR xp x64 sp2) AND .net 2.0 sp2 AND 3.5 sp1 - GDR
IF : Aspnet_wp.exe version is less than 2.0.50727.3618
Windows : File Test :  Aspnet_wp.exe version is less than 2.0.50727.3618 
At least one of the objects listed below must exist on the system (Existence check)
Windows : File Aspnet_wp.exe
[[value of ${{windows:registry_object:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion : SystemRoot}}]]\Microsoft.NET\Framework\v2.0.50727\aspnet_wp.exe
version less than 2.0.50727.3618 (datatype=version)
version is less than 2.0.50727.3618 windows : file_state 
IF : Any one of the following are true
Prerequisites (Extended Definitions)
Microsoft .NET Framework 2.0 Service Pack 2 is installed oval:org.mitre.oval:def:6158
Microsoft .NET Framework 3.5 Service Pack 1, or later, is installed oval:gov.nist.fdcc.patch:def:11583
IF : Any one of the following are true vista sp1 (32/64) OR 2008 RTM (32/64) OR xp sp3 OR xp x64 sp2
Prerequisites (Extended Definitions)
Microsoft Windows Server 2008 (32-bit) is installed oval:org.mitre.oval:def:4870
Microsoft Windows XP (x86) SP3 is installed oval:org.mitre.oval:def:5631
Microsoft Windows XP x64 Edition SP2 is installed oval:org.mitre.oval:def:4193
Microsoft Windows Vista x64 Edition Service Pack 1 is installed oval:org.mitre.oval:def:5254
Microsoft Windows Server 2008 (64-bit) is installed oval:org.mitre.oval:def:5356
Microsoft Windows Server 2008 (ia-64) is installed oval:org.mitre.oval:def:5667
Microsoft Windows Vista (32-bit) Service Pack 1 is installed oval:org.mitre.oval:def:4873

Quick Help

References To Objects
[[ .. ${{...}}]] are refences to values of other objects.
Other Help Topics
Data Types
What is an Object?
What is a State?
What is a Test?
Other Help Topics
Regular Expression Patterns
Some object or state definitions are defined as regular expression patterns, you should interpret the regexp pattern while evaluating them.

OVAL Definitions By Referenced Objects

How does it work?   User agreement and privacy statement   About & Contact
CVE is a registred trademark of the MITRE Corporation and the authoritive source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritive source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritive source of OVAL content is MITRE's OVAL web site.
Warning: This site and all data are provided as is. It is not guaranteed that all information is accurate and complete. Use any information provided on this site at your own risk. By using this site you accept that you know that these data are provided as is and not guaranteed to be accurate, correct or complete. All trademarks appearing on this site are the property of their respective owners in the US or other countries. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss. PLEASE SEE nvd.nist.gov and oval.mitre.org for more details about OVAL language and definitions.
The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor/web site owner/maintainer be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.
Use of OVAL and all related data is subject to terms of use defined by Mitre at http://oval.mitre.org/oval/about/termsofuse.html