Patch  oval:org.mitre.oval:def:27634
DEPRECATED: ELSA-2013-0685 -- perl security update (moderate) (Deprecated)  

[4:5.10.1-130] - Resolves: #915692 - CVE-2012-5526 (newline injection due to improper CRLF escaping in Set-Cookie and P3P headers) - Resolves: #915692 - CVE-2012-6329 (possible arbitrary code execution via Locale::Maketext) - Resolves: #915692 - CVE-2013-1667 (DoS in rehashing code)
Create Date: 2014-11-05 Last Update Date: 2015-02-10

Affected Platforms/Products

Affected Products (CPE + CVE references)
Platforms: unix (from OVAL definitions) Products: unix
  • Oracle Linux 6
  • Oracle Linux 5
  • perl

References

Criteria

The patch should be installed
IF : Any one of the following are true
IF : All of the following are true Oracle Linux 5 release section
Prerequisites (Extended Definitions)
Oracle Linux 5.x oval:org.mitre.oval:def:15459
IF : Any one of the following are true Packages match section
IF : perl is earlier than 0:5.8.8-40.el5_9
Linux : RPM Test :  perl is earlier than 0:5.8.8-40.el5_9 
At least one of the objects listed below must exist on the system (Existence check)
RPM Version less than 0:5.8.8-40.el5_9 (datatype=evr_string)
version is earlier than 0:5.8.8-40.el5_9 linux : rpminfo_state 
IF : perl-suidperl is earlier than 0:5.8.8-40.el5_9
Linux : RPM Test :  perl-suidperl is earlier than 0:5.8.8-40.el5_9 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-suidperl
RPM Version less than 0:5.8.8-40.el5_9 (datatype=evr_string)
version is earlier than 0:5.8.8-40.el5_9 linux : rpminfo_state 
IF : All of the following are true Oracle Linux 6 release section
Prerequisites (Extended Definitions)
Oracle Linux 6.x oval:org.mitre.oval:def:16594
IF : Any one of the following are true Packages match section
IF : perl-CPANPLUS is earlier than 0:0.88-130.el6_4
Linux : RPM Test :  perl-CPANPLUS is earlier than 0:0.88-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-CPANPLUS
RPM Version less than 0:0.88-130.el6_4 (datatype=evr_string)
version is earlier than 0:0.88-130.el6_4 linux : rpminfo_state 
IF : perl-suidperl is earlier than 0:5.10.1-130.el6_4
Linux : RPM Test :  perl-suidperl is earlier than 0:5.10.1-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-suidperl
RPM Version less than 0:5.10.1-130.el6_4 (datatype=evr_string)
version is earlier than 0:5.10.1-130.el6_4 linux : rpminfo_state 
IF : perl-parent is earlier than 0:0.221-130.el6_4
Linux : RPM Test :  perl-parent is earlier than 0:0.221-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-parent
RPM Version less than 0:0.221-130.el6_4 (datatype=evr_string)
version is earlier than 0:0.221-130.el6_4 linux : rpminfo_state 
IF : perl-libs is earlier than 0:5.10.1-130.el6_4
Linux : RPM Test :  perl-libs is earlier than 0:5.10.1-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-libs
RPM Version less than 0:5.10.1-130.el6_4 (datatype=evr_string)
version is earlier than 0:5.10.1-130.el6_4 linux : rpminfo_state 
IF : perl-core is earlier than 0:5.10.1-130.el6_4
Linux : RPM Test :  perl-core is earlier than 0:5.10.1-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-core
RPM Version less than 0:5.10.1-130.el6_4 (datatype=evr_string)
version is earlier than 0:5.10.1-130.el6_4 linux : rpminfo_state 
IF : perl-Time-Piece is earlier than 0:1.15-130.el6_4
Linux : RPM Test :  perl-Time-Piece is earlier than 0:1.15-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Time-Piece
RPM Version less than 0:1.15-130.el6_4 (datatype=evr_string)
version is earlier than 0:1.15-130.el6_4 linux : rpminfo_state 
IF : perl-Time-HiRes is earlier than 0:1.9721-130.el6_4
Linux : RPM Test :  perl-Time-HiRes is earlier than 0:1.9721-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Time-HiRes
RPM Version less than 0:1.9721-130.el6_4 (datatype=evr_string)
version is earlier than 0:1.9721-130.el6_4 linux : rpminfo_state 
IF : perl-Test-Simple is earlier than 0:0.92-130.el6_4
Linux : RPM Test :  perl-Test-Simple is earlier than 0:0.92-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Test-Simple
RPM Version less than 0:0.92-130.el6_4 (datatype=evr_string)
version is earlier than 0:0.92-130.el6_4 linux : rpminfo_state 
IF : perl-Pod-Escapes is earlier than 0:1.04-130.el6_4
Linux : RPM Test :  perl-Pod-Escapes is earlier than 0:1.04-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Pod-Escapes
RPM Version less than 0:1.04-130.el6_4 (datatype=evr_string)
version is earlier than 0:1.04-130.el6_4 linux : rpminfo_state 
IF : perl-Pod-Simple is earlier than 0:3.13-130.el6_4
Linux : RPM Test :  perl-Pod-Simple is earlier than 0:3.13-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Pod-Simple
RPM Version less than 0:3.13-130.el6_4 (datatype=evr_string)
version is earlier than 0:3.13-130.el6_4 linux : rpminfo_state 
IF : perl-Term-UI is earlier than 0:0.20-130.el6_4
Linux : RPM Test :  perl-Term-UI is earlier than 0:0.20-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Term-UI
RPM Version less than 0:0.20-130.el6_4 (datatype=evr_string)
version is earlier than 0:0.20-130.el6_4 linux : rpminfo_state 
IF : perl-Test-Harness is earlier than 0:3.17-130.el6_4
Linux : RPM Test :  perl-Test-Harness is earlier than 0:3.17-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Test-Harness
RPM Version less than 0:3.17-130.el6_4 (datatype=evr_string)
version is earlier than 0:3.17-130.el6_4 linux : rpminfo_state 
IF : perl-Parse-CPAN-Meta is earlier than 0:1.40-130.el6_4
Linux : RPM Test :  perl-Parse-CPAN-Meta is earlier than 0:1.40-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Parse-CPAN-Meta
RPM Version less than 0:1.40-130.el6_4 (datatype=evr_string)
version is earlier than 0:1.40-130.el6_4 linux : rpminfo_state 
IF : perl-Params-Check is earlier than 0:0.26-130.el6_4
Linux : RPM Test :  perl-Params-Check is earlier than 0:0.26-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Params-Check
RPM Version less than 0:0.26-130.el6_4 (datatype=evr_string)
version is earlier than 0:0.26-130.el6_4 linux : rpminfo_state 
IF : perl-Module-Load is earlier than 0:0.16-130.el6_4
Linux : RPM Test :  perl-Module-Load is earlier than 0:0.16-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Module-Load
RPM Version less than 0:0.16-130.el6_4 (datatype=evr_string)
version is earlier than 0:0.16-130.el6_4 linux : rpminfo_state 
IF : perl-Module-Load-Conditional is earlier than 0:0.30-130.el6_4
Linux : RPM Test :  perl-Module-Load-Conditional is earlier than 0:0.30-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Module-Load-Conditional
RPM Version less than 0:0.30-130.el6_4 (datatype=evr_string)
version is earlier than 0:0.30-130.el6_4 linux : rpminfo_state 
IF : perl-Module-Loaded is earlier than 0:0.02-130.el6_4
Linux : RPM Test :  perl-Module-Loaded is earlier than 0:0.02-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Module-Loaded
RPM Version less than 0:0.02-130.el6_4 (datatype=evr_string)
version is earlier than 0:0.02-130.el6_4 linux : rpminfo_state 
IF : perl-Module-Pluggable is earlier than 0:3.90-130.el6_4
Linux : RPM Test :  perl-Module-Pluggable is earlier than 0:3.90-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Module-Pluggable
RPM Version less than 0:3.90-130.el6_4 (datatype=evr_string)
version is earlier than 0:3.90-130.el6_4 linux : rpminfo_state 
IF : perl-Object-Accessor is earlier than 0:0.34-130.el6_4
Linux : RPM Test :  perl-Object-Accessor is earlier than 0:0.34-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Object-Accessor
RPM Version less than 0:0.34-130.el6_4 (datatype=evr_string)
version is earlier than 0:0.34-130.el6_4 linux : rpminfo_state 
IF : perl-Package-Constants is earlier than 0:0.02-130.el6_4
Linux : RPM Test :  perl-Package-Constants is earlier than 0:0.02-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Package-Constants
RPM Version less than 0:0.02-130.el6_4 (datatype=evr_string)
version is earlier than 0:0.02-130.el6_4 linux : rpminfo_state 
IF : perl-Module-Build is earlier than 0:0.3500-130.el6_4
Linux : RPM Test :  perl-Module-Build is earlier than 0:0.3500-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Module-Build
RPM Version less than 0:0.3500-130.el6_4 (datatype=evr_string)
version is earlier than 0:0.3500-130.el6_4 linux : rpminfo_state 
IF : perl-Module-CoreList is earlier than 0:2.18-130.el6_4
Linux : RPM Test :  perl-Module-CoreList is earlier than 0:2.18-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Module-CoreList
RPM Version less than 0:2.18-130.el6_4 (datatype=evr_string)
version is earlier than 0:2.18-130.el6_4 linux : rpminfo_state 
IF : perl-Log-Message-Simple is earlier than 0:0.04-130.el6_4
Linux : RPM Test :  perl-Log-Message-Simple is earlier than 0:0.04-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Log-Message-Simple
RPM Version less than 0:0.04-130.el6_4 (datatype=evr_string)
version is earlier than 0:0.04-130.el6_4 linux : rpminfo_state 
IF : perl-Log-Message is earlier than 0:0.02-130.el6_4
Linux : RPM Test :  perl-Log-Message is earlier than 0:0.02-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Log-Message
RPM Version less than 0:0.02-130.el6_4 (datatype=evr_string)
version is earlier than 0:0.02-130.el6_4 linux : rpminfo_state 
IF : perl-Locale-Maketext-Simple is earlier than 0:0.18-130.el6_4
Linux : RPM Test :  perl-Locale-Maketext-Simple is earlier than 0:0.18-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Locale-Maketext-Simple
RPM Version less than 0:0.18-130.el6_4 (datatype=evr_string)
version is earlier than 0:0.18-130.el6_4 linux : rpminfo_state 
IF : perl-IO-Compress-Zlib is earlier than 0:2.020-130.el6_4
Linux : RPM Test :  perl-IO-Compress-Zlib is earlier than 0:2.020-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-IO-Compress-Zlib
RPM Version less than 0:2.020-130.el6_4 (datatype=evr_string)
version is earlier than 0:2.020-130.el6_4 linux : rpminfo_state 
IF : perl-IPC-Cmd is earlier than 0:0.56-130.el6_4
Linux : RPM Test :  perl-IPC-Cmd is earlier than 0:0.56-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-IPC-Cmd
RPM Version less than 0:0.56-130.el6_4 (datatype=evr_string)
version is earlier than 0:0.56-130.el6_4 linux : rpminfo_state 
IF : perl-IO-Zlib is earlier than 0:1.09-130.el6_4
Linux : RPM Test :  perl-IO-Zlib is earlier than 0:1.09-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-IO-Zlib
RPM Version less than 0:1.09-130.el6_4 (datatype=evr_string)
version is earlier than 0:1.09-130.el6_4 linux : rpminfo_state 
IF : perl-IO-Compress-Bzip2 is earlier than 0:2.020-130.el6_4
Linux : RPM Test :  perl-IO-Compress-Bzip2 is earlier than 0:2.020-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-IO-Compress-Bzip2
RPM Version less than 0:2.020-130.el6_4 (datatype=evr_string)
version is earlier than 0:2.020-130.el6_4 linux : rpminfo_state 
IF : perl-IO-Compress-Base is earlier than 0:2.020-130.el6_4
Linux : RPM Test :  perl-IO-Compress-Base is earlier than 0:2.020-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-IO-Compress-Base
RPM Version less than 0:2.020-130.el6_4 (datatype=evr_string)
version is earlier than 0:2.020-130.el6_4 linux : rpminfo_state 
IF : perl-File-Fetch is earlier than 0:0.26-130.el6_4
Linux : RPM Test :  perl-File-Fetch is earlier than 0:0.26-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-File-Fetch
RPM Version less than 0:0.26-130.el6_4 (datatype=evr_string)
version is earlier than 0:0.26-130.el6_4 linux : rpminfo_state 
IF : perl-ExtUtils-ParseXS is earlier than 0:2.2003.0-130.el6_4
Linux : RPM Test :  perl-ExtUtils-ParseXS is earlier than 0:2.2003.0-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-ExtUtils-ParseXS
RPM Version less than 0:2.2003.0-130.el6_4 (datatype=evr_string)
version is earlier than 0:2.2003.0-130.el6_4 linux : rpminfo_state 
IF : perl-ExtUtils-MakeMaker is earlier than 0:6.55-130.el6_4
Linux : RPM Test :  perl-ExtUtils-MakeMaker is earlier than 0:6.55-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-ExtUtils-MakeMaker
RPM Version less than 0:6.55-130.el6_4 (datatype=evr_string)
version is earlier than 0:6.55-130.el6_4 linux : rpminfo_state 
IF : perl-ExtUtils-Embed is earlier than 0:1.28-130.el6_4
Linux : RPM Test :  perl-ExtUtils-Embed is earlier than 0:1.28-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-ExtUtils-Embed
RPM Version less than 0:1.28-130.el6_4 (datatype=evr_string)
version is earlier than 0:1.28-130.el6_4 linux : rpminfo_state 
IF : perl-ExtUtils-CBuilder is earlier than 0:0.27-130.el6_4
Linux : RPM Test :  perl-ExtUtils-CBuilder is earlier than 0:0.27-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-ExtUtils-CBuilder
RPM Version less than 0:0.27-130.el6_4 (datatype=evr_string)
version is earlier than 0:0.27-130.el6_4 linux : rpminfo_state 
IF : perl-Digest-SHA is earlier than 0:5.47-130.el6_4
Linux : RPM Test :  perl-Digest-SHA is earlier than 0:5.47-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Digest-SHA
RPM Version less than 0:5.47-130.el6_4 (datatype=evr_string)
version is earlier than 0:5.47-130.el6_4 linux : rpminfo_state 
IF : perl-Compress-Zlib is earlier than 0:2.020-130.el6_4
Linux : RPM Test :  perl-Compress-Zlib is earlier than 0:2.020-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Compress-Zlib
RPM Version less than 0:2.020-130.el6_4 (datatype=evr_string)
version is earlier than 0:2.020-130.el6_4 linux : rpminfo_state 
IF : perl-Compress-Raw-Zlib is earlier than 0:2.020-130.el6_4
Linux : RPM Test :  perl-Compress-Raw-Zlib is earlier than 0:2.020-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Compress-Raw-Zlib
RPM Version less than 0:2.020-130.el6_4 (datatype=evr_string)
version is earlier than 0:2.020-130.el6_4 linux : rpminfo_state 
IF : perl-devel is earlier than 0:5.10.1-130.el6_4
Linux : RPM Test :  perl-devel is earlier than 0:5.10.1-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-devel
RPM Version less than 0:5.10.1-130.el6_4 (datatype=evr_string)
version is earlier than 0:5.10.1-130.el6_4 linux : rpminfo_state 
IF : perl-Compress-Raw-Bzip2 is earlier than 0:2.020-130.el6_4
Linux : RPM Test :  perl-Compress-Raw-Bzip2 is earlier than 0:2.020-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Compress-Raw-Bzip2
RPM Version less than 0:2.020-130.el6_4 (datatype=evr_string)
version is earlier than 0:2.020-130.el6_4 linux : rpminfo_state 
IF : perl is earlier than 0:5.10.1-130.el6_4
Linux : RPM Test :  perl is earlier than 0:5.10.1-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
RPM Version less than 0:5.10.1-130.el6_4 (datatype=evr_string)
version is earlier than 0:5.10.1-130.el6_4 linux : rpminfo_state 
IF : perl-Archive-Extract is earlier than 0:0.38-130.el6_4
Linux : RPM Test :  perl-Archive-Extract is earlier than 0:0.38-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Archive-Extract
RPM Version less than 0:0.38-130.el6_4 (datatype=evr_string)
version is earlier than 0:0.38-130.el6_4 linux : rpminfo_state 
IF : perl-Archive-Tar is earlier than 0:1.58-130.el6_4
Linux : RPM Test :  perl-Archive-Tar is earlier than 0:1.58-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-Archive-Tar
RPM Version less than 0:1.58-130.el6_4 (datatype=evr_string)
version is earlier than 0:1.58-130.el6_4 linux : rpminfo_state 
IF : perl-CGI is earlier than 0:3.51-130.el6_4
Linux : RPM Test :  perl-CGI is earlier than 0:3.51-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-CGI
RPM Version less than 0:3.51-130.el6_4 (datatype=evr_string)
version is earlier than 0:3.51-130.el6_4 linux : rpminfo_state 
IF : perl-CPAN is earlier than 0:1.9402-130.el6_4
Linux : RPM Test :  perl-CPAN is earlier than 0:1.9402-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-CPAN
RPM Version less than 0:1.9402-130.el6_4 (datatype=evr_string)
version is earlier than 0:1.9402-130.el6_4 linux : rpminfo_state 
IF : perl-version is earlier than 0:0.77-130.el6_4
Linux : RPM Test :  perl-version is earlier than 0:0.77-130.el6_4 
At least one of the objects listed below must exist on the system (Existence check)
Linux : RPM Package 
perl-version
RPM Version less than 0:0.77-130.el6_4 (datatype=evr_string)
version is earlier than 0:0.77-130.el6_4 linux : rpminfo_state 

Quick Help

evr_string datatype
Represents epoch, version, and release number as a single version string
Other Help Topics
Data Types
What is an Object?
What is a State?
What is a Test?
Other Help Topics
Regular Expression Patterns
Some object or state definitions are defined as regular expression patterns, you should interpret the regexp pattern while evaluating them.

OVAL Definitions By Referenced Objects

How does it work?   User agreement and privacy statement   About & Contact
CVE is a registred trademark of the MITRE Corporation and the authoritive source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritive source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritive source of OVAL content is MITRE's OVAL web site.
Warning: This site and all data are provided as is. It is not guaranteed that all information is accurate and complete. Use any information provided on this site at your own risk. By using this site you accept that you know that these data are provided as is and not guaranteed to be accurate, correct or complete. All trademarks appearing on this site are the property of their respective owners in the US or other countries. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss. PLEASE SEE nvd.nist.gov and oval.mitre.org for more details about OVAL language and definitions.
The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor/web site owner/maintainer be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.
Use of OVAL and all related data is subject to terms of use defined by Mitre at http://oval.mitre.org/oval/about/termsofuse.html